Monday, February 28, 2011

vSphere 4.1 vCenter Server will not start

Issue: customer said that he is unable to connect to his new physical vCenter server which was working fine few days ago.
Resolution:
checked the VMware vCenter service and it was stopped.
Started the vCenter service but no go.
In the vCenter service properties used a specified account for login but no go.
Customer said that he has not rebooted the vCenter server.
Customer gets the error
|vcenter server could not connect to "vcenter". A connection failure occurred(unable to connect to the remote server)|
when he attempts to log into the vCenter server using the vSphere client.
Customer said that Wednesday was the last successful login.
KB Article: 1007669
made the sqlserver as the dependency service for the vCenter server service to start and rebooted the server and tried to relogin but no go.
When checked the services.msc the service was still starting but later it failed to start and manually starting the service did not help us to relogin but it yielded the same result.
<http://www.ozvms.com/index.php?option=com_content&view=article&id=553:virtualcenter-vpxd-command-line-switches&catid=50:tech-tips&Itemid=49>
Ran the command C:\Program Files\VMware\Infrastructure\VirtualCenter Server\vpxd.exe -s
and it came up with the error that the transaction log is full.
Tried to download and install the sql server management studio express but it threw an error while installing
|The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 29506.|
Disabled UAC and tried reinstalling it but no go.
1.Right click on desktop and click NEW – SHORTCUSTOMERT


2. Create shortcustomert to C:\Windows\SysWOW64\cmd.exe
3. Right click on the new shortcustomert and Run AS ADMINISTRATOR
4. Enter full path and file name: C:\Users\[YOUR NAME]\Downloads\SQLServer2005_SSMSEE_x64.msi
KB Article: 1003980
Issue Resolved.

vSphere 4.1 Unable to access the console for VMs

Issue: The host has a yellow error symbol on it. when customer tries to access the service console for the VMs inside the hosts he gets the error message
|unable to connect to the MKS: vim.fault.InvalidLogin|
Resolution: KB Article: 1004837
customer did not have a cluster.
Restarted the VMware management agents.
Issue Resolved.



Wednesday, February 23, 2011

HTC Desire HD will not sync or detect the HTC Sync software (Resolved)

Scenario: The issue is common to many of the HTC mobile phones. I have a HTC Desire HD. I have installed latest HTC Desire Sync software from their website. When the phone is connected in front USB ports it will not get detected or the HTC Sync software says that no device connected. If connected to the USB ports at the back of the computer it will get detected but the internet passthrough (using the PC internet on phone) and USB Tethering (using the phone's internet on PC) will not work. rest of the options work fine.

Issues : Unable to use the phone as modem for internet (usb tethering)
Unable to PC internet on HTC Desire HD
Unable to sync HTC Desire HD
Unable to detect the HTC Desire HD
PC and/or HTC Sync software is not detecting the HTC Desire HD
HTC Desire HD is not detecting the HTC Sync software or the amd.exe in your computer.

Configuration: Windows 7 Ultimate x64, Windows Security Essential, HTC Sync Software

Causes: If HTC Sync software that you have downloaded and the HTC Desire Sync that you have purchased are not from the same country then you will face this problem.
I have purchased the handset in india and i have to go to htc.com/in and download the software and then only it will work since the unique IMEI number embedded in the handset determines the country.
If you have downloaded the software from a different country website of HTC (using a proxy, or at the office VPN network) then it will install the driver meant for that country's IMEI numbered handsets which conflicts with your handset.
Resolution: Uninstall the existing HTC Sync software
Uninstall the existing HTC BMP USB driver
Uninstall the existing HTC Driver
Reboot.
Completely disable the antivirus or the security software in your computer by either
***start>run>msconfig>general>selective start up>services tab>hide all microsoft services>start up>uncheck your security softwares or antivirus softwares.
Reboot
OR
Turn off the security software till you install the HTC Sync by going to settings.
OR
Turn off real time protection from your security softwares by going to the settings
Disconnect your existing internet connection and/or disable it.
Disconnect all mobile devices including HTC Desire HD.
Install the HTC Sync software(which includes the USB DMP Driver and the HTC Driver )that you have downloaded from same country's website of HTC where you have bought the handset. (ask the HTC tech support if you are not sure which country your HTC handset's IMEI number belongs to!)
Now connect your HTC Handset to the front/back USB port and a menu will pop for you to choose the way the HTC Handset to be used as, choose anything and all the options should work.

Saturday, February 12, 2011

ESX 4 No COS Swap Configured


Issue: When customer rebooted the hosts after an HP P400i SAN upgrade he saw a red message on the welcome screen
0:00:02:10.526 cpu0:4096)No COS Swap Configured.
Customer was also unable to power on the virtual machines due an error "insufficient resources"







This is a known issue with ESX 4 Update 1 but it can happen to other versions as well.
What worked :
blkid | grep swap
/dev/sdX: TYPE="swap" UUID="a.....1.....z"
where X is the device identifier.
swapon /dev/sdbX
nano /etc/fstab and update the UUID of the swap from the output of blkid | grep swap
reboot the host with
shutdown -r now
and there was no error and cu was able to power on the virtual machines.
The solution given from the kb.vmware.com is very sloppy and confusing.
What Helped:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1016297
http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=1019442&sliceId=1&docTypeID=DT_KB_1_1&dialogID=153060662&stateId=0%200%20155669818

Friday, February 11, 2011

ESXi/ESX 4.x Ghost nics on multiple windows VMs after changing hardware version & upgrading vmware tools

Issue:
When the customer tries to check the tcp/ip settings and when clicked on ok it gives an error "the ip address 10.247.35.45 you have entered for this adapter is already assigned to another adapter 'Intel(R) PRO/1000 MT Network Connection # 2' on this computer. If the same address is assigned to both the adapters and they both become active, only one of them will use this address. This may result in incorrect system configuration.
Do you want to fix the problem by entering a different IP address for this adapter in the list of IP addresses in the Advanced dialog box?"
and when clicked on No for the above error cu gets another error “Warning: Multiple default gateways are intended to provide redundancy to a
single network such as and Intranet or the Internet. They will not function
properly when the gateways are on two separate, disjoint networks (such as
one on your intranet and one on the Internet). Do you want to save this
configuration? “.
Solution:
Tried This
http://remotexpert.net/blog/2009/11/how-to-fix-error-the-ip-address-you-have-entered-for-this-network-adapter-is-already-assigned-to-another-adapter-name-of-adapter/
but no go.
.
Tried the devcon.exe tool from microsoft to remove the ghost nics but no go.
Unpack the 32 bit or 64 bit DevCon tool binary to a local folder.
Click Start > Run, type cmd, and press Enter.
Type CD:\path_to_binaries to navigate to the devcon.exe.
devcon listclass net
devcon remove @device\name reboot.
After the reboot the VM asked for one more reboot since it has detected and installed a new device and thus we rebooted.
After the reboot the VM had lost all the network configuration and customer assigned the ip information but when he tried click ok to save changes he again got the same error but we stilled clicked on ok to have multiple default gateways and rebooted and this time the networking icon was present for the first time after this issue has started.
set devmgr_show_nonpresent_devices=1 and checked the device manager>show hidden devices>network adapters but found no dimmed network adapters.
The most important thing to note here is there was no nic which was grayed out because in VMs which are converted from p2v this is the common issue.
checked HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkCards\
and there were 2 network card information 2 and 13.
Helped customer to delete the key named 2 and reboot but no go.
but no go.


SOLUTION WHICH WORKED: Remove the e1000 nics and add vmxnet3 nics.

Sunday, February 6, 2011

html Hover tag over text

Let us say that you are writing and article or a poem and you want to add a description to a word without opening a pop up window the reader should be able to see the description on the same page.
Linux
HOVER YOUR MOUSE HERE.
now when you use the tag in the above line instead of the word 'Linux' itself then the description appears as a small hover text above the word linux.