Friday, January 17, 2014

Unable to add VMXNET 3 with solaris 10 update 5.x on ESX 4.0

ISSUE:
After adding the VMXNET 3 and installing the driver and rebooting the VM customer is unable to connect to the network and ifconfig –a will not show the VMXNET 3 interface. Customer has the latest VMware tools installed.
ENVIRONMENT:
VMware OS: ESX 4.0 Update 1
VM OS: Solaris 10 (Update 5)
SOLUTION:
Take a snapshot before trying any of the steps below as a precaution.
*Install the e1000 ethernet interface on the Solaris VM.
*Install the latest VMware tools on the VM.
*Power off the VM.
*Install the second NIC onto a solaris VM using the VMXNET 3 driver.
*ifconfig VMXNET3s0 plumb
*ifconfig e1000g0 unplumb
*mv /etc/hostname.e1000g0 /etc/hostname.VMXNET3s0
*reboot the VM
CAUSE:
This particular issue was an ongoing issue with the ESX 3.5. The /etc/hostname.xxxx file tells the solaris which network interface has to be used and even though the VMXNET 3 drivers are installed properly the /etc/hostname.xxxx has to be changed or edited to inform the solaris which network interface has to be used and in this scenario we have to changed it to /etc/hostname.VMXNET3s0 so that the solaris will try to use the VMXNET 3 network interface.
Note:
1] Do not remove the e1000 interface from the VMware VM configuration.
2] If the VM is using the DHCP then do the following as well
mv /etc/dhcp.e1000g1 /etc/dhcp.VMXNET3s0
SOURCE:
a) http://mydigitalbrain.blogspot.com/2009/12/solaris-10-and-vmware-VMXNET-ethernet.html