Thursday, July 17, 2014

HP Blades with ESXi 5.x fail to display hardware status!

Issue : When you go to hardware status of the esxi 5.x host we get an error "hardware monitoring service on this host is not responding or not available".

Cause : iLO 2 firmware version 2.07

Resolution: Upgrade iLO 2 firmware version to 2.09/2.15/2.25 or higher.

Image: HP Custom Esxi 5.x

What didn't work:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1013080
it is not a DMZ site.
/etc/init.d/sfcbd-watchdog restart
got an error in the command saying
< sh: bad number
sh: you need to specify whom to kill >
reconnected the host and checked the hardware status but got an error
"hardware status communication error with the server"
tried to restart the sfcbd-watchdog process but the command got hung.
https://communities.vmware.com/thread/458686
checked firewall setting by looking Configuration (Tab) -> Security Profile -> Firewall; according to the Firewall page, the CIM Server service runs on both TCP ports 5988 and 5989.
disabled symantic end point, restarted the inventory service, did a update/refresh of the hardwae status tab but no go.
the hardware status plugin 5.5 is installed and enabled in the vcenter server.
http://www.everything-virtual.com/2011/03/hardware-status-not-displaying-on-vsphere-client-fix/
but no go.
tried restarting the cim server but it failed with an error saying the remote server took too long.
tried stopping the cim server but it failed with the same error.
issue seems to be with the servers but not vcenter since vcenter is working with 2 hosts.
Applied all the HP patches and udpates for the host via the update manager but no go.